Participant issue in the Japanese Region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Sep 01, 2026 - 06:29 UTC

Investigating

We are currently investigating an issue with participants missing from EX Projects and Directory in the Japanese Region.
Posted Sep 01, 2026 - 02:48 UTC
This incident affected: Projects.