Survey taking and dashboard loading issues in the Asia Pacific region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Aug 18, 2025 - 01:58 UTC

Investigating

We are currently investigating an issue affecting survey taking when an organisation hierarchy question is embedded, as well as dashboard loading problems in the Asia Pacific region
Posted Aug 18, 2025 - 00:40 UTC
This incident affected: Surveys (Survey Taking) and Dashboards.