Dashboard data ingestion latency issue in the Eastern US region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted May 08, 2026 - 02:43 UTC

Investigating

We are currently investigating an issue with dashboard data ingestion latency in the Eastern US region.
Posted May 08, 2026 - 01:50 UTC
This incident affected: Dashboards.