Dashboard export issues in All Regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jun 03, 2025 - 03:02 UTC

Investigating

We are currently investigating an issue affecting certain widgets in dashboard exports across all regions. In dashboard exports, certain widgets may appear truncated or overlapping, preventing clients from viewing their data. The affected widgets include Response Ticker, Scorecard, and Question List.
Posted Jun 03, 2025 - 01:31 UTC
This incident affected: Dashboards.