EX platform issues in European region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Nov 21, 2023 - 21:42 UTC

Investigating

We are currently investigating an issue that is impacting the EX platform including Survey Taking, Distributions, and Dashboards in the European region.
Posted Nov 21, 2023 - 21:23 UTC
This incident affected: Surveys (Survey Taking), Distributions (Email, SMS (Text)), and Dashboards.