Online Review Management issues in All Regions

Incident Report for Qualtrics

Update

We are continuing to work on a fix for this issue.
Posted Mar 02, 2026 - 10:51 UTC

Identified

We are ingesting new reviews but synchronisation of updates and deletes is currently impaired due to issues on Google's side.
Posted Mar 02, 2026 - 07:51 UTC
This incident affects: Data Processing.