Loading issues in European Region
Incident Report for Qualtrics
Resolved
This incident has been resolved.
Posted Aug 02, 2022 - 04:17 UTC
Investigating
We are currently investigating an issue with latency and errors on the Projects page, Dashboards, and Reports in the European Region.
Posted Aug 02, 2022 - 03:27 UTC
This incident affected: Surveys (Survey Editing) and Dashboards, Reports.