Look and Feel issues in All Regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Feb 05, 2025 - 21:22 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 05, 2025 - 20:33 UTC

Update

We are continuing to investigate this issue.
Posted Feb 05, 2025 - 19:53 UTC

Investigating

We are currently investigating an issue with accessing the look and feel tab in the survey builder in all regions.
Posted Feb 05, 2025 - 19:53 UTC
This incident affected: Surveys (Survey Editing).