Dashboard data delay issues in the Singaporean region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted May 22, 2025 - 19:01 UTC

Update

We are continuing to investigate this issue.
Posted May 21, 2025 - 07:11 UTC

Investigating

We are currently investigating an issue with dashboard data ingestion in the Singaporean region.
Posted May 21, 2025 - 07:03 UTC
This incident affected: Data Processing.