Errors when starting surveys from personal links in the Eastern US region

Incident Report for Qualtrics

Resolved

This incident has been resolved
Posted Nov 27, 2023 - 20:52 UTC

Investigating

We are currently investigating an issue with surveys started from personal links experiencing errors and latency in our Eastern US region.
Posted Nov 27, 2023 - 20:47 UTC
This incident affected: Surveys (Survey Taking).