EX Survey Editing issues in all regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Mar 18, 2023 - 02:54 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 17, 2023 - 20:32 UTC

Investigating

We are currently investigating an issue with editing shared EX surveys in all regions.
Posted Mar 17, 2023 - 19:04 UTC
This incident affected: Surveys (Survey Editing).