Discover Studio Connectors UI and data processing issues in the European region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Feb 28, 2025 - 12:53 UTC

Investigating

We are investigating a data processing issue in the European region, and the connectors tab is currently unavailable for affected accounts
Posted Feb 28, 2025 - 11:53 UTC
This incident affected: Data Processing and Discover Studio (EU Endpoint: https://studio.fra1.qualtrics.com/dashboard/).