Ticket API run delays in Canadian region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Oct 09, 2025 - 19:38 UTC

Update

We are continuing to investigate this issue.
Posted Oct 09, 2025 - 15:46 UTC

Update

We are continuing to investigate this issue.
Posted Oct 09, 2025 - 15:45 UTC

Investigating

We are currently investigating an issue with delays in API runs related to Ticketing in Canadian region.
Posted Oct 09, 2025 - 15:44 UTC
This incident affected: API / Developer Platform.