Discover Connector issues in US region Environments

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Jul 26, 2025 - 14:37 UTC

Investigating

Our US region environments are experiencing issue with Discover Connector UI and XMlink connector. We are currently investigating this.
Posted Jul 26, 2025 - 13:33 UTC
This incident affected: Discover Studio (US Endpoint: https://studio.us1.qualtrics.io/dashboard/).