Ongoing Dashboard Maintenance
Incident Report for Qualtrics
Resolved
This maintenance has been completed and users should now be able to recache their dashboards and make changes in the data mapper without issue.
Posted Jul 31, 2022 - 16:09 UTC
Identified
Dashboards are continuing to undergo maintenance from the maintenance scheduled earlier this morning.

During this time users in the Western US Region will be unable to make changes in their dashboard data mappers to recache dashboards.
Posted Jul 31, 2022 - 15:23 UTC
This incident affected: Dashboards.