Dashboard issues in Asia Pacific region

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Apr 15, 2026 - 22:39 UTC

Investigating

We are currently investigating an issue with dashboards in the Asia Pacific region. Dashboard widgets may fail to display data at this time.
Posted Apr 15, 2026 - 22:05 UTC
This incident affected: Dashboards.