Survey Platform navigation and Distribution issues in FedRAMP Region.

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 12:27 UTC

Investigating

We are currently investigating issues with navigating the website Survey platform (e.g Survey Editing, Projects and Catalog) and distributions in the FedRAMP Region.
Posted Mar 09, 2026 - 06:04 UTC
This incident affected: Distributions (Email, SMS (Text)), Surveys (Survey Editing), and Projects.