Distribution issues in the European region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Oct 04, 2025 - 17:05 UTC

Investigating

We are currently investigating an issue with distribution delays and failures in the European region.
Posted Oct 04, 2025 - 16:14 UTC
This incident affected: Distributions (Email, SMS (Text)).