Issues for Brand Admins using Admin tab in in all regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Nov 04, 2025 - 19:12 UTC

Investigating

We are currently investigating an issue within the Admin tab in all regions. Brand Admins may be unable to view or edit features in the Users and Groups subtabs at this time.
Posted Nov 04, 2025 - 18:20 UTC
This incident affected: Administration.