Delay in displaying workflow histories in all regions.
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Oct 29, 2024 - 04:48 UTC
Investigating
We are currently investigating an issue with delays in displaying workflow histories in all regions.
Posted Oct 29, 2024 - 00:57 UTC
This incident affected: Workflows.