Latency during Survey Taking in the European region
Incident Report for Qualtrics
Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 12:33 UTC
Investigating
We are currently investigating an issue with latency during Survey Taking in the European region.
Posted Nov 05, 2024 - 10:55 UTC
This incident affected: Surveys (Survey Taking).