Email distributions issue in the European region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Oct 22, 2024 - 02:19 UTC
Update
We are continuing to investigate this issue.
Posted Oct 22, 2024 - 02:18 UTC
Investigating
We are currently investigating increased bounce rates across email distributions in the European Region. Some distributions sent from the European Region can bounce.
Posted Oct 22, 2024 - 01:54 UTC
This incident affected: Distributions (Email).