Distribution issues in Eastern US Region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Nov 28, 2022 - 17:51 UTC
Investigating
We are currently investigating an issue with distribution failures in the Eastern US Region.
Posted Nov 28, 2022 - 16:09 UTC
This incident affected: Distributions (Email, SMS (Text)).