Distributions issues in Western US region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 20:28 UTC

Investigating

We are currently investigating an issue with distributions being delayed in the Western US region.
Posted Aug 27, 2025 - 19:39 UTC
This incident affected: Distributions (Email, SMS (Text)).