Email and SMS Distribution issues in multiple regions

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Oct 21, 2025 - 15:14 UTC

Investigating

We are currently investigating an issue with Email and SMS distributions in European, Canadian, and Western and Eastern US regions.
Posted Oct 21, 2025 - 14:51 UTC
This incident affected: Distributions (Email, SMS (Text)).