Latency in Eastern US region

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 02:51 UTC

Update

We are continuing to investigate this issue.
Posted Jul 03, 2025 - 01:54 UTC

Update

We are continuing to investigate this issue.
Posted Jul 03, 2025 - 01:53 UTC

Investigating

We are currently investigating this issue.
Posted Jul 03, 2025 - 01:43 UTC
This incident affected: Surveys (Survey Taking, Survey Editing), Distributions (Email, SMS (Text)), XM Directory & Contacts (XM Directory Automations, XM Directory Imports, Directory Contacts), Website / App Insights (WAI Project Editing, Session Replay, Visitor Intercept Display), and Logins, Data Processing, Projects, Administration, Dashboards, Reports, Workflows, Ticketing, API / Developer Platform.