Dashboard Filtering issues in all regions.

Incident Report for Qualtrics

Resolved

The issue has been resolved.
Posted Aug 14, 2026 - 01:00 UTC

Investigating

We are currently investigating an issue with items not populating in dashboard filter dropdown menus in all regions.
Posted Aug 13, 2026 - 23:58 UTC
This incident affected: Dashboards.