Discover Connector Failures in European Regions

Incident Report for Qualtrics

Resolved

This incident has been resolved.
Posted Dec 15, 2025 - 02:38 UTC

Identified

The issue has been identified and recovery is in progress.
Posted Dec 15, 2025 - 02:35 UTC

Investigating

We are currently investigating the Discover Connector issues being seen in our European regions.
Posted Dec 15, 2025 - 00:56 UTC
This incident affected: Discover Studio (EU Endpoint: https://studio.fra1.qualtrics.com/dashboard/).