Distribution delays in the Eastern US Region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Nov 19, 2024 - 00:20 UTC
Investigating
We are currently investigating an issue causing delays in both SMS and Email distributions in our Eastern US Region.
Posted Nov 18, 2024 - 23:49 UTC
This incident affected: Distributions (Email, SMS (Text)).