Scheduled reports issues in Eastern US region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Oct 03, 2022 - 18:48 UTC
Investigating
We are currently investigating an issue with delays in processing scheduled reports emails in the Eastern US region.
Posted Oct 03, 2022 - 15:31 UTC
This incident affected: Reports.