Dashboard Notification issues in Eastern US region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Jan 22, 2023 - 20:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 20, 2023 - 01:03 UTC
Investigating
We are investigating an ongoing issue that is preventing the distribution of weekly/monthly Dashboard Notifications in the Eastern US region.
Posted Jan 19, 2023 - 18:36 UTC
This incident affected: Dashboards.