Issues when signing up for Free Qualtrics accounts
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Jul 27, 2022 - 20:57 UTC
Investigating
We are currently investigating an issue with signing up for Free Qualtrics accounts. This does not impact any user with an existing Qualtrics account.
Posted Jul 27, 2022 - 20:34 UTC
This incident affected: Logins.