Dashboard latency issues in European region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Jun 23, 2022 - 17:03 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 23, 2022 - 15:20 UTC
Investigating
We are currently investigating elevated dashboard latency in European region
Posted Jun 23, 2022 - 10:31 UTC
This incident affected: Dashboards.