Dashboard loading issues in the Eastern US region
Incident Report for Qualtrics
Resolved
The issue with dashboards failing to load intermittently has been resolved.
Posted Jun 16, 2022 - 19:21 UTC
Investigating
We are currently investigating an issue with loading dashboards in the Eastern US region.
Posted Jun 16, 2022 - 18:13 UTC
This incident affected: Dashboards.