Public API latency in Eastern US region
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Feb 06, 2023 - 16:52 UTC
Investigating
We are currently investigating an issue with elevated Public API latency in the Eastern US region.
Posted Feb 03, 2023 - 20:57 UTC
This incident affected: API / Developer Platform.