Workflow task editing issues in all regions
Incident Report for Qualtrics
Resolved
The issue has been resolved.
Posted Oct 05, 2022 - 20:26 UTC
Update
We are continuing to investigate this issue.
Posted Oct 05, 2022 - 20:01 UTC
Investigating
We are currently investigating an issue with editing some Workflow tasks in all regions. There are no issues with firing existing Workflows.
Posted Oct 05, 2022 - 19:47 UTC
This incident affected: Workflows.