Live Support issues
Incident Report for Qualtrics
Resolved
This issue has been resolved.
Posted Jan 26, 2023 - 20:54 UTC
Investigating
We are currently investigating issues with our ticketing system. Phone calls currently are unable to be placed and there may be a delay in responses to chat and email tickets. Our team is actively working on a resolution as quickly as possible. We apologize for any inconvenience this may cause.
Posted Jan 26, 2023 - 20:32 UTC
This incident affected: Support (Live Support).